728x90
✔ [BOJ/9498] 시험 성적
문제
시험 점수를 입력받아 90 ~ 100점은 A, 80 ~ 89점은 B, 70 ~ 79점은 C, 60 ~ 69점은 D, 나머지 점수는 F를 출력하는 프로그램을 작성하시오.
입력
첫째 줄에 시험 점수가 주어진다. 시험 점수는 0보다 크거나 같고, 100보다 작거나 같은 정수이다.
출력
시험 성적을 출력한다.
예제 입력
100
예제 출력
A
알고리즘 분류
- 구현
코드
import java.util.*;
public class Main {
public static void main(String[] args){
int a;
Scanner in = new Scanner(System.in);
a = in.nextInt();
if(a>=90){
System.out.println("A");
} else if(a>=80){
System.out.println("B");
} else if(a>=70) {
System.out.println("C");
} else if(a>=60){
System.out.println("D");
} else {
System.out.println("F");
}
}
}
조건문
if문
if / else문
if / else / if 문
'Algorithm & Data Structure > boj' 카테고리의 다른 글
✔ [BOJ/14681] 사분면 고르기 (3) | 2022.02.03 |
---|---|
✔ [BOJ/2753] 윤년 (2) | 2022.02.02 |
✔ [BOJ/1330] 두 수 비교하기 (0) | 2022.01.31 |
✔ [BOJ/2588] 곱셈 (2) | 2022.01.28 |
✔ [BOJ/10430] 나머지 (4) | 2022.01.27 |