728x90
✔ [BOJ/8393] 합
문제
n이 주어졌을 때, 1부터 n까지 합을 구하는 프로그램을 작성하시오.
입력
첫째 줄에 n (1 ≤ n ≤ 10,000)이 주어진다.
출력
1부터 n까지 합을 출력한다.
예제 입력
3
예제 출력
6
알고리즘 분류
- 구현
- 수학
코드
import java.util.*;
public class Main {
public static void main(String args[]) {
Scanner in = new Scanner(System.in);
int input = in.nextInt();
int sum = 0;
for(int i=1;i<input+1;i++){
sum += i;
}
System.out.println(sum);
}
}
대입 연산자
'Algorithm & Data Structure > boj' 카테고리의 다른 글
✔ [BOJ/15552] 빠른 A+B (0) | 2022.02.12 |
---|---|
✔ [BOJ/10950] A+B - 3 (4) | 2022.02.07 |
✔ [BOJ/2739] 구구단 (2) | 2022.02.06 |
✔ [BOJ/2884] 알람 시계 (1) | 2022.02.04 |
✔ [BOJ/14681] 사분면 고르기 (3) | 2022.02.03 |